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1.1 General

1.1.1 Introduction

The UO-EM-AME/M module can be connected to the Unit One modules at any position and provides the
system with an Ethernet interface.
This interface supports standard and fast Ethernet (10/100 Mb). The speed is detected and adjusted
automatically.
Modbus TCP is used as the protocol.
The module provides the following initial data:

- Position

- ERC data

- Status and diagnosis

- Communications counter

- Connection details

- Operating time

The following functions can also be parameterised:
- Counting direction
- Presetvalue
- Lower limit switch
- Upper limit switch

1.1.2 Modbus TCP

MODBUS is a protocol at Level 7 of the OSI model.
It has been the industry standard since 1979.
Access to the Ethernet is via port 502 on the TCP/IP protocol stack.

More detailed information and the relevant protocol specifications are available on the Modbus user
organisation’s website (www.modbus.org, www.modbus-ida.org).

1.2 Connection and network configuration

1.2.1 Network topology

Various connection possibilities are available for the Ethernet.
The simplest choice is direct connection to a PC (PLC). A Cat. 5 crossover cable needs to be used here.
Another option is to use a hub or a switch. In both these cases, a normal Cat. 5 patch cable needs to be used.

Cat. 5 crossover
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Cat. 5 patch

Electronic function module UO-EM-AME/M

Cat. 5 patch

1.2.2 Connection of the module

oooo Hub/switch

Power is supplied via the Unit One LWL-D2 module.
The Ethernet port is designed as an RJ45 socket. Standard Cat. 5 cables can be used.

Pin assignment of the socket:

RJ45 pin

Signal

1

TX+

TX-

RX+

Not used

Not used

RX-

Not used

|IN|O|Oa|bM[W[IN

Not used
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1.2.3 Diagnosis LEDs

STATUS

00

«—— Connected/activity 10 Mb

Connected/activity 100 Mb

X1

UO-AME/M

The four LEDs indicate the relevant status of the module.

The two LEDs in the RJ45 socket indicate the relevant network activity. One lights up when the module is
connected in the network and flashes when there is any activity. The yellow LED indicates 10 Mb and the
green LED 100 Mb. The two status LEDs (green and red) indicate the module’s current operating status.

The table below lists the possible statuses and associated displays.

Operational Status LWL Network Network TCP Status LEDs
status flag decoder module status status Red G
connection e reen
Start-up - - - - - Off Off
Preliminary _ No _ _ _ on Off
operation
Not Flashes
- Ve identified - - sooms | Off
. Flashes
- Yes Identified - - On 500 ms
Transition - - - - - On On
. Flashes
Operation 0 - - Connected Other Off 250 ms
Not Flashes
v B B Carreeid connected o 500 ms
0 - - Connected | Connected Off On
0 _ _ Not _ Flashes | Insync
connected 500 ms | withred
Parameter _ _ _ _ Flashes | Inverts to
invalid 250 ms red
Programming - - - - ;?g?ﬁ: Off
Error - - - - On Off

UserManual AME_M_Module_En R1-(2017-01-18)/D70983 doc



O HANNE S S—

H__U,E!\INE_R Electronic function module UO-EM-AME/M

ideas and solutions

1.2.4 Network configuration

Once the Unit One operating software has started up, an overview screen of all addressable modules appears.
To change the network settings, you need to use the mouse to choose the “Change” pushbutton in the
“AME/ERC Unit” field.

x|
Datei Bearbeiten ?
— 1 H AN N E S —
HUBNER
— S E N —
Fabrik elektrischer Maschinen GmbH

Main - Unit

M ain L/
I5/M= 00438331
[Firmrussare= L4-2.0--

e JE o] St |

Choose this pushbutton

The next screen then appears. Here, you can configure the IP address, subnet mask and default gateway.
The default settings are:

IP address: 192.168.1.2

Subnet mask: 255.255.255.0

Default gateway: 0.0.0.0

Once you have configured this data, choose “Program”. If you want to cancel the procedure, choose “Close”.

Datei Bearbeiten ?
T T pa—
e HUBNER
k. ST E N —
/ Fabrik elektrischer Maschinen GmbH
Gerat wird ausgelesen. Bitte Warten /
Main - Unit
[Main LWL
I5/M= 00438331
Firmware= L4-2.0--

IP Einstellungen

IP-Adresse ez[l |2
Subnetzmaske - [255 (255 [255 [0
Gateway o [0 Jo o

Schishen Programmisren

When you choose “Program”, the AME/M module is reset and restarts with the new settings.
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1.3 Datatransfer

1.3.1 Modbus parameters

The response time of the module is > 5 ms. The overall response time also depends on the network load and
structure. The client’s timeout time (time waited until a response is received) needs to be configured
accordingly.

The module is addressed via the IP address. The “MODBUS Unit Identifier” is therefore not important for the
module (this parameter is required for other interfaces). It is ignored by the AME/M module. The module
inserts in the response the byte received. This byte may take on any value (0x00 — OxFF).

We recommend that you set this value to OXFF (0x00 is also possible).

The AME/M module has an input memory for the TCP packages. This means that it can handle several
requests “simultaneously”. The Modbus parameter “NumberMaxOfServerTransaction” can be set to 10.

Port 502 is reserved for the Modbus transfer and must be used.

The module can edit a TCP connection. If a second connection is opened, the first is closed.

1.3.2 Supported function codes
The following Modbus function codes are supported:

- 01 (0x01) Read Coils

- 02 (0x02) Read Discrete Inputs

- 03 (0x03) Read Holding Registers
- 04 (0x04) Read Input Registers

- 05 (0x05) Write Single Coil

- 06 (0x06) Write Single Register

- 16 (0x10) Write Multiple Registers

The different function codes all access the same memory area.
In Modbus, the high-order byte is first transferred (“big endian”). Memory space is assigned in the same way.

1.3.3 Modbus memory assignment table

Register Name Data format Valency Coil no. Byte Access
no. type
0 2% 2% 0-7 0
it 21 2% 8-15 1
positon value & UINT 32 S Read
1 imit switch flags 2°_2 16 — 23 2
2° -2 24 -31 3
2% - 2% 32-39 4
2 ERC data UINT 16 B Read
27-2 40 — 47 5
3 Error flags UINT 16 48 - 55 6 Read
. ea
Warnings & status (bit array) 56 — 63 7
2% 2" 64— 71 8
4 Communications counter UINT 16 R Read
2°-2 72-79 9
28 - 2% 80 — 87 10
5 For future reference UINT 16 R Read
27 -2 88 - 95 11
5 Parameter flags UINT 16 96 — 103 12 Read/writ
. ead/write
Process flags (bit array) 104-111 | 13
2% 2% | 112-119 | 14
! o _ 2% 2% | 120-127 | 15 _
Limit switch min. UINT 32 RT3 Read/write
8 2°-2 128 - 135 16
2°-2' 136-143 | 17
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Register Name Data format Valency Cail no. Byte Access
no. type
22423 | 144-151 18
9 - 2622 | 152-159 19 _
Limit switch max. UINT 32 SRS Read/write
222 160 — 167 20
10 —
2°-2 168 — 175 21
22423 | 176-183 | 22
1 222 | 184-191 | 23 _
Preset value UINT 32 ST Read/write
222 192 - 199 24
12 ——
2°-2 200 - 207 25
2821 208-215 | 26 _
13 For future reference UINT 16 T Read/write
2°-2 216 — 223 27
22423 | 224-231 | 28
14 2622 | 232-239 | 29 _
For future reference UINT 32 TR Read/write
222 240 — 247 30
15 T
2°-2 248 -255 | 31
2821 256 —263 | 32
16 Software version UINT 16 R Read
2°-2 264 — 271 33
2821 272-279 | 34
17 Hardware version UINT 16 R Read
2°-2 280 — 287 35
22423 | 288-295 | 36
18 2622 | 206-303 | 37
Serial number UINT 32 T Read
222 304 — 311 38
19 —
2°-2 312 -319 39
2%4_2% | 320-327 | 40
20 216 _2% | 328-335 | 41
IP address UINT 32 TR Read
2®_2 336-343 | 42
21 —
2°-2 344 — 351 43
2%4_2% | 352-359 | 44
22 2 _2% | 360-367 | 45
Subnet mask UINT 32 T Read
2®_2 368-375 | 46
23 —
2°-2 376-383 | 47
2%4_2% | 384-301 | 48
24 26 _2% | 392-399 | 49
Default gateway UINT 32 TR Read
2®_2 400 — 407 50
25 T
2°-2 408 -415 | 51
224 _2% | 416-423 | 52
26 26 _2% | 424-431 | 53
Operating time UINT 32 BT Read
2%_2 432 — 439 54
27 —
2°-_2 440 — 447 55
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1.3.4 Position & limit switch
The position value has a value range of 24 bit (12 bit multi-turn and 12 bit single turn). Bits 30 and 31 are used
for the limit switch function (like in CAN and Profibus).
The special feature of these two bits is activated in the “process flags”.
Position (24 bit)
31| 30 23 16 | 15 8 | 7 |.|.|.|-]-]-].-] O |Bit
7 0| 15 8 |23 16 |31 |.|.|.|.|-|.|-| 24 | Coil no.
Bit 31: Limit switch max.
Bit 30: Limit switch min.
1.3.5 ERCdata
The ERC data is stored in Register 2. Unused bits are transferred as 0.
Switch points 1 — 6 (R1 — R6) Switch points 7 — 12 (R7 — R12)
- - R6 | R5 | R4 | R3 | R2 | R1 - - | R12 | R11 | R10 | R9 | R8 | R7 | Switch
15 | 14 | 13 | 12 | 11 | 10 9 8 7 6 5 4 3 2 1 0 | Bit
39 | 38 | 37 | 36 | 35 | 34 | 33 | 32 | 47 | 46 | 45 44 43 | 42 | 41 | 40 | Coil no.
1.3.6 Error flags & status flags
These flags are stored in Register 3 as illustrated.
Error flags Warnings & status
15 | 14 | 13 | 12 | 11 | 10 9 8 7 6 5 4 3 2 1 0 Bit
55 | 564 | 53 | 52 | 51 | 50 | 49 | 48 | 63 | 62 61 60 59 58 | 57 | 56 Coil no.
The following error messages are supported:
Coil no. Error flag Cause
48 Memory error (NVRAM) The data in the NVRAM is invalid.
49 Checksum incorrect Invalid data is constantly being received from the
encoder.
50 No signal from the encoder No data is being received from the encoder.
51 Jump error The encoder data is not consistent.
52 For future reference
53 For future reference
54 For future reference
55 For future reference

Where one of these flags is set, the last valid position value will always be transferred.
The ERC data is set to 0.

UserManual_AME_M_Module_En-R1-(2017-01-18)ID70983.doc
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Possible status and warning messages:

Coil no. Warnings & status Cause

56 Device ready Device has started up correctly.

57 Parameterisation invalid The client is attempting to write incorrect data.
58 Handshake signal Is set for read accesses.

59 Warning encoder data transfer ?;]kéi;‘;igg?ncy of errors with the encoder data is
60 For future reference

61 For future reference

62 For future reference

63 For future reference

A warning flag is for information purposes only. All data continues to be consistent. The functionality is not
impaired.

1.3.7 Communications counter

This value is incremented with each valid Modbus access. Its memory address is Register 4.

Communications counter

15 | 14 | 13 | 12 | 11 | 10 9 8 7 6 5 4 3 2 1 0 Bit

55 | 54 | 53 | 52 | 51 | 50 | 49 | 48 | 63 | 62 | 61 60 59 | 58 | 57 | 56 Coil no.

This enables “life monitoring” to be set up. This counter is processed by the main CPU.
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1.3.8 Parameter flags & process flags
These flags are stored in Register 6 as illustrated.
Parameter flags Process flags
15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0 Bit
103 | 102 | 101 | 100 | 99 | 98 | 97 | 96 | 111 | 110 | 109 | 108 | 107 | 106 | 105 | 104 | Coil no.
Parameter flags:
Coil no. Parameter flag Function
96 Counting direction Position value increases during right or left rotation
97 Limit switch min. active Enable limit switch min. (bottom)
98 Limit switch max. active Enable limit switch max. (top)
929 For future reference
100 For future reference
101 For future reference
102 For future reference
103 For future reference
Process flags:
Coil no. Process flag Function
104 For future reference
105 For future reference
106 For future reference
107 For future reference
108 For future reference
109 For future reference
110 Set preset The position value is set to the preset value.
111 Transfer data Confirmation of a write access.
1.3.9 Limit switch min.
This value is stored in registers 7 and 8.
Limit switch min. (24 bit
S [Tz T[T [ []] ] [a][7 [T ]][I]o s
119-112 127 - 120 135-128 143 — 136 Coil no.
1.3.10 Limit switch max.
This value is stored in registers 9 and 10.
Limit switch max. (24 bit)
S LIz L [T [T [ss[ [ [ ][] [a]7 [T ]]I]o [
151 -144 159 - 15 167 — 160 175 - 168 Coil no.
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1.3.11 Preset value

This value is stored in registers 11 and 12.

Preset value max. (24 bit)

] [Tz [T [l 1118l 7. . .1.1.1.[.]o s
183 -176 191 - 184 199 — 192 207 — 200 Coil no.
1.3.12 Software version
This value is stored in Register 16 as illustrated.
Position 1 Position 2 Position 3 Position 4
15 [ 141312 |unfw|o|8 |76 ][5 ]4]3]2]1]o0 Bit
263 — 260 259 — 256 271 - 268 267 — 264 Coil no.
A nibble is used for each position.
The value 0x0210 means Version 02.10.
1.3.13 Hardware version
This value is stored in Register 17 as illustrated.
Position 1 Position 2 Position 3 Position 4
15 [ 141312 |1nfw|o|8 |7 |6 ][5 ]4a]3]2]1]o0 Bit
279 - 276 275 - 272 287 — 284 283 — 280 Coil no.
A nibble is used for each position.
The value 0x0120 means Version 01.20.
1.3.14 Serial number
This value is stored in registers 18 and 19.
Serial number (24 bit)
S Lz L Ts [as L[ [I.le 7 [T].] ][]0 fex
295 — 288 303 — 296 311 - 304 319 - 312 Coil no.
The number is stored as a figure.
The value 0x00049444 means: SN=300100.
1.3.15 IP address
This value is stored in registers 20 and 21.
IP address
A [T T[T [ss[ [T [e] 7] ]I o [ex
295 — 288 303 — 296 311 - 304 319 — 312 Coil no.
The value OXC0OA80102 means: IP address = 192.168.1.2.
1.3.16 Subnet mask
This value is stored in registers 22 and 23.
Subnet mask
S [ I T[T [ss[ [T ][] 7 [ ][] I]o [en
359 — 352 367 — 360 375 — 368 383 — 369 Coil no.

The value OXFFFFFFO0 means: Subnet mask = 255.255.255.0.
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1.3.17 Default gateway

This value is stored in registers 24 and 25.

Electronic function module UO-EM-AME/M

Default gateway
S L]z L Tee [as LTI le 7 [T].[ T[] o [en
391 — 384 399 — 392 407 — 400 415 — 408 Caoil no.
The value 0XAAB51E01 means: Default gateway = 170.181.30.1.
1.3.18 Operating time
This value is stored in registers 26 and 27.
Operating time
A T[Tz T[T [ss] [T 7] ]I o [ex
423 - 416 431 - 424 439 — 432 447 — 440 Caoil no.

The resolution is 0.1 h.
The value 0x00006CD9 means: Operating time = 2786.5 h.

1.3.19

Write data

If data is to be written to the memory (function codes 5, 6, 16), the following procedure must be followed:

Write data to a valid address.
The AME/M module sets the handshake flag (Coil 58) and starts the monitoring period.

Set the “Transfer data” flag (Coil 111).

The AME-M module carries out the following:
The data is transferred to the process memory and NVRAM.
The handshake flag (Coil 58) is cleared.

The “Transfer data” flag (Coil 111) is cleared.
The data will now be used for the calculation.

If this procedure is not followed, the data will be replaced with the data from the NVRAM at the end of the
monitoring period and the handshake flag cleared. The internal calculations will not be affected.

Correct transfer:

]

Write data

Handshake (Coil 58)

I
1

Transfer data (Coil 111)
Monitoring period active
(internal)

| | Data > NVRAM (internal)

NVRAM - data (internal)

Error, “Transfer data” not set:

Write data

11
_

Handshake (Coil 58)

Transfer data (Coil 111)
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Monitoring period active
(internal)

Data > NVRAM (internal)

|_| NVRAM - data (internal)

Error, monitoring period exceeded (> 2s):

_|_| Write data
|

| Handshake (Coil 58)

|_| Transfer data (Coil 111)

Monitoring period active
(internal)

Data 2 NVRAM (internal)

|_| NVRAM -> data (internal)

1.4 Parameterisation

1.4.1 Counting direction

The “Counting direction” flag (Coil 96) is used to specify whether the actual process value increases or
decreases when the shaft is rotated to the right.
The direction of rotation can be determined by looking at the shaft end.

. . . “Counting direction” flag
Direction of rotation (Coil 96)
Right 0
Left 1

1.4.2 Limit switch min.

The “Limit switch min. active” flag (Coil 97) can be used to specify whether the lower limit switch is output in
the actual process value.

. “Limit switch min. active” flag
Output in the actual process value (Coil 97)
Off 0
On 1

1.4.3 Limit switch max.

The “Limit switch max. active” flag (Coil 98) can be used to specify whether the upper limit switch is output in
the actual process value.

. “Limit switch max. active” flag
Output in the actual process value (Coil 98)
Off 0
On 1
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1.4.4 Preset

The preset value is written to registers 11 and 12. Once it has been written here correctly, the preset is,
however, still not set. It is set using the “Set preset” flag (Coil 110).

Each time this flag is set, a new internal offset is calculated, saved in the NVRAM and displayed as the current
position value. The “Set preset” flag (Coil 110) is then cleared by the AME/M module. The position value is
subsequently equal to the preset value.

A new preset value can also be transferred at the same time as the set “Set preset” flag (with Command 16,
Write Multiple Registers). The preset is then set immediately.
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1.5 Electrical data

Power supply: 12VDC...30VDC, connection via UO EM-D2
Power consumption: 1W max.
Design: Flat module, integrated in modular electronic housing with bus connector
Dimensions: W =225mm
H =99 mm
D =115 mm

Connection technology: RJ45 plug

Resolution: 12 bit (4,096 revolutions)
12 bit (4,096 steps per revolution)

Temperature range: 0°Cto+70°C
Interface: Modbus TCP
Baud rates: 10/100 Mb
Network address: Configurable
99 { B— 8

| SISIISIIIS

5 o
2]

VA

.

TAETAL LT, '//
 E 40 J_’_;/‘/;/_/J/_/,_/.//////// ./%

Gehausebreite [B]: 22,5 mm
Gehausehohe [A]: 114,5 mm

Housing width [B]: 22.5 mm

Housing height [A]: 114.5 mm
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1.6 Unit One UO-SM-AME_ERC Electronic Position Switch

1.6.1 Introduction
The electronic position switch UO SM-AME_ERC is integrated in the AME unit as software module. The
absolute value data produced by the UO EM-AME will be prepared in the electronic position switch and will
be compared with 12 programmable switching ranges with one switching-on and switching-off position
each. The switching point output is effected via a 2 byte information which is component of the process
data output of the UO EM-AME.

The programming of the position switch and therewith also determination of the switching ranges is only
affected via a PC (e.g. Laptop) via the central serial interface (RS232) of the UO EM-D2.

1.6.2 Technical data
Outputs: Switching positions:
2 software switches via process data output of the UO EM-AME

as 2 byte information

Operating range: single turn mode 12 bit
Multi turn mode 12 bit

1.7 Operating the software

Launch the configuration program (UONE)

The UONE overview screen opens to provide a graphic overview of the connected modules.
[Muone - x|

— ) O HAN N E S, m—
HUBNER
— S S E N E—

Fabrik elektrischer Maschinen GmbH

Version 2.x Rev 4.0

are=L4-22-

T

Now click the "Start" button in the AME - Unit graphic icon to launch the program ERCPro3.
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File View Options Help

mm  Current pos.

— QHANNE S —
HUBNER
— S S E N —
Licence infomation
* Company : [
Contact person: [

Telephone number [

eMail l

W Save

T
Change basic
setting

Read
Programming
Range [0 Jmm Measure

I

Complete the fields in the Licence information dialog box, then click the "Save" button.

The Licence information dialog box will then close.
x|

& ERCPro3 <UOne>
File View Options Help.

please start ABS-Read

mm  Cunent pos.

i

[T T T T I

ing position _mm

Preset setting

[
I
I
I
i

[
I
[
I
II
i\

-l
Read

—
. =

Data must be read-out of the module. To do so, click the "Read" button. Data from the module populate the
fields.
A flashing yellow dot signalizes that position data is being read out of the module.

1.8 Change default settings

@ ERCPro3 <UOne>
Fie View Options Help

e
%/ — —

Range [ 0 Jem Measure

It is possible to change the basic ERC unit settings (dark-grey shaded area).
To do so, click the "Change basic settings" button.
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x|

@ ERCPro3 <UOne>
Fie View Options Help

MATTENTION! Change basic
settings has consequence on max. switch
points. Count direction change has
consequence on absolut value

S/N

ERC Firmware
(6] 100 | 1o | =
e [7] _edit
—

- Negative value
- Enror handling
[R5 100 | 1o |
[on [0 ] Hysteresis

Count ditection [,

(el o0 | oo |
[ov [ ]

[AS] 100 [ oo |
[ on [ ]

(2] o0 [ oo |

(W] w0 [ o]
[on 57 ]

Close basic
setting

Programming

1. SIN
This field displays the serial number of the module; this information is read only and cannot be changed.

2. ERCPro Ver.
This field displays the version of the programming software; this information is read only and cannot be changed.

3. ERC Firmware

This field displays the firmware version of the UO-SM-ERC — module; this information is read only and cannot be
changed.

4. Negative value
When the Negative value box is selected, the displayed value range is placed in the middle of the value range of
the basic unit. The display can now display positive and negative numbers.

5. Preset setting
The preset value for the module is entered in this field. This value is transmitted immediately to the UO-EM-AME
module when you click the "Preset setting” button.
The position value is always set to this value when the hardware input "Preset setting” is activated.

6. Hysteresis
The switching hysteresis is entered in this field (switch-on and reset hysteresis of the relays). The value is
entered in encoder increments (1-255). This determines the difference between the switch-on and switch-off
points of a switching point.

7. Count direction

The selected option determines if the position value increases when the encoder shaft is turning in a clockwise
or anti-clockwise direction.

8. Factor
It is possible to enter a conversion factor in this field. Raw encoder data are multiplied by this factor and
displayed.
Caution!!!
Any changes to this setting will influence the switching points. You will need to check and possibly adapt the
corresponding settings (see chap. 1.9).

9. Unit

It is possible to select a character string from the Unit drop-down list, which is displayed as the unit of the
displayed values. It is also possible to define the character string in the system settings.
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10.Identification
The character string entered in this field serves to identify the module. The user is able to choose the characters
in the string up to a maximum of eight characters.

11.Last edit
The date data was last transmitted to the module is displayed in this field.

To write the data to the module click the button "Programming”. By contrast, if you do not wish to save the edited
data click the "Close basic setting" button.

1.9 Change switching points
x|

cm  Cunent pos.

(AT AT I

1000

2
g

Range [ 0 Jem

It is possible to adjust the range of the graphic display by entering positions in both "Range" fields.

The ERC module offers 12 independent channels, each of which has a relay as output stage. 2 switching
points can be assigned to each channel. The programmed switching range may also exceed the zero
reference point.

The switch-on points are entered in the left field, and the switch-off point points in the right field. When entering
the switching points please note that they are scaled according to the set "factor”. The value range of the
encoder (factor = 1) is 0 to 224-1 (16777215).

Several options are available to the user to complete the fields:
- Enter value manually.

- Click the value in the field "Current pos." and copy the value to the target field by holding down the left mouse button in
a drag-and-drop operation

- Hold down the left mouse button to move the yellow bar. The lower limiting arrow moves the entire bar, the upper
limiting arrow changes the length of the bar.

It is possible to invert the switching function of the channel by double-clicking "ON" or "OFF".

Click the "Programming” button to write and save the new values to the ERC module.
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1.10 Measure function

The "Measure" function is an aid that makes it possible to determine the scaling factor. It can be used when
the scaling factor of the system is unknown. It is essential when using the program that the speed ratio
between the mounted position of the encoder and the axis to be configured is constant and there is a linear
relation between the axis position and the data word of the encoder.

To start the function, click the "Measure" button.

[ercpros <vone> x

1. Set machine to 1. Position and entes measured value in

1. Position’
1. Position 1. Abs-value
Setting Pos.1
2. Set machine to 2. Position and enter measured value in ‘2.
Position"
2. Position 2. Abs-value
3. Distance and Factor will be calculated
Distance Unit Factor
(13 I Cancel |

Caution! The absolute value of position 1 must be less than the absolute value of position 2; moreover, zero
crossing is not allowed between these two positions.
The accuracy of the calculation is greater when both positions on the axis are as far apart as possible.

Move the axis to the first position. The current raw encoder data are displayed in the field "1. Abs-value". Now
enter the desired value in the field "1. Position". To apply the data, click the "Setting Pos. 1" button.

Now move the axis to the second position. The current raw encoder data are displayed in the field "2. Abs-
value". Now enter the desired value in the field "2. Position". To apply the data, click the "Setting Pos. 2"
button. The factor will now be calculated and displayed in the field "Factor".

Click the "OK" button to store the value in the buffer memory. Click the "Cancel" button to abort the procedure
and close the dialog box.

The message "Factor = xxxxx" is now displayed in the message area of the UONE overview screen. If you wish
to use this value, you must enter it in the field "Factor" (see Change basic settings).
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1.11 Pulldown-Menu ,file®

In the File menu it is possible to save, load and print out data as well as change program settings.
I| File View Options Help

Load..
Save as..

Print

Settings
Exit ->UOne

1100

=

Read parameters

"File>Load.." opens the "Open *.DAT file" dialog box. Select and load the parameter file (*.DAT) into the
programming software.

To be able to transmit the data to the module, you must click the "Programming" button.

Caution! The preset value is not transmitted and must be set separately.

2. Save parameters
"File->Save as.." opens the Save as dialog box. To save the parameters (settings) select a destination folder
and specify a file name for the parameter file (*.DAT).

3. Print
File = Print" prints the parameter on the standard printer.

4. Exit
"File > Exit ->U-One" terminates the program and launches the configuration program (UONE).

1.12 Pulldown-Menu ,file > settings*

fﬁ; View Options Help
Load..
Save as..

Print

X Simulation
Exit ->UOne
Language »
System

Programsettings

1. Communication port
"File > Settings > ComPort" opens the Comm-Port Settings dialog box.

/s Comm-Port Settings x|

Comm-Port [

&

Test Port 9 NOP

Settings
Close

Under normal circumstances users are not required to use this menu item, because the settings in the configuration
program (UONE) have already been set. If it is not possible to establish a communications with the module, carry out the
settings as described in chapter 1.7 Configuration of the software).
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2. Simulation

Electronic function module UO-EM-AME/M

"File = Settings = Simulation" sets the software to "showroom" mode to be used for demonstration purposes

only.

3. Select language
"File > Settings ->Language" enables the user to set the desired user interface languag.

Selection

Deutsch
English
User

4. Factory settings
"File > Settings > System" launches a menu to request a code.
It is only possible to request a code over the phone.

X

Please give this CODE to Hiibner by phone oK
and put our reply into text field —]

Cancel

Phone no. : +49 641 / 7969 43
Detail Info
ERCPro version : 3.x Rev 9.0
Fimware : ERCSV 7.3
Licence for : sdfsdf
Current Serial No.: 999888
CPU-Time : 0.000

Code : 2512609F17

Reply : |

User interface
Deutsch

English

Is not longer supported
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5. Program settings
"File = Settings - Programsettings" opens the Programsettings dialog box.

™ read after save

™ Frimware scann first ERC than ERCS

~ View
I~ Show mesages I no splashscreen

Benutzerdefinierte Einheit

- Logfile save
I~ Logfile save
|g— read retry

Commandline. I ?
Save Cancel

User selectable settings are listed in the table below.

Description Function

read after save After the switching points are
programmed the "read" command is
executed (corresponds to clicking the
"Read" button).
This function is always activated no
matter what selection is made.

Firmware scan first ERC then ERCS | This setting is required for other devices
and is of no relevance in this instance.

Show messages Activates additional messages.

no splashscreen Program information is not displayed
when the program is launched.

User defined unit Text field for user defined unit.
This is determined when making basic
settings.
The characters are saved locally on the
PC.

Logfile save Save data communication with the
module to a file.

read retry It is possible to enter a value in this field
in the event communication problems
arise (< 10).
Communications are slowed if the value
is too high.

Commandline This is reserved for future programming
options, it remains unused.
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1.13 Pulldown-Menu ,,View*
Settings for the graphic user interface are made in this menu.

I File IWew Options  He

v Actual value
Reverse indication
Graphic 2

v differense
Coloring >
Format
Log-File

1. Position display
"View - Actual value" switches the position display bar on or off in the switch graphic overview.

2. Zero reference point of position display
"View > Reverse indication" reverses the fields displaying the range view (top <-> bottom).

3. Position display
"View - Graphic 2" opens the GRAPHIC 2 overview with a different representation of the actual position.

4. Difference display
"View -> Difference" switches the display showing the difference between the switching points (relay on
range) on and off.

5. Coloring
"View - Coloring" allows the user to define the color representation of the graphic interface. You must
close and relaunch the software for the changes to take effect.

6. Format option
"View > Format" enables the user to select the display resolution. It is possible to make this setting
independent of the position display and the switching points.
To confirm this setting click the "Read" button.

7. Display log file
"View > Log-File" opens the log file in an editor.

1.14 Pulldown menu "Options"
"Options - Visual setting" switches the option on and off that enables the user to set the switching points by moving
the bars.

1.15 Pulldown menu "Help"
"Help = Info ERCPro3" displays the program information dialog box.
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1.16 EU- Declaration of Conformity

=== JOHANNES EU-Konformitatserklarung

HuBNER (EU-Richtlinie 2014/30/EU)
= EU-Declaration of Conformity
(EU-Directive 2014/30/EU)

Hersteller / Manufacturer: Johannes Hubner Fabrik elektrischer Maschinen GmbH
Anschrift / Address: 35394 Giessen, Siemensstrasse 7
Produktbezeichnung / Product designation:

Elektronik-Funktionsmodul UO-EM-AME/M
Electronic function module UO-EM-AME/M

Die bezeichneten Produkte stimmen in der von uns in Verkehr gebrachten Ausfiihrung mit
den Vorschriften folgender Europdischer Richtlinien liberein:

The products described above in the form as placed on the market are in conformity with the
provisions of the following European Directive:

2014/30/EU (Ausgabe / Version 2014-02-26)

Richtlinie des Europaischen Parlaments und des Rates vom 26. Februar 2014 zur Harmonisierung
der Rechtsvorschriften der Mitgliedstaaten iber die elektromagnetische Vertraglichkeit

Directive 2014/30/EU of the European Parliament and of the Council of 26 February 2014 on the
harmonisation of the laws of the Member States relating to electromagnetic compatibility

DIN EN 55011 (Ausgabe / Version 2011-04) Industrielle, wissenschaftliche und medizinische
Gerate - Funkstorungen - Grenzwerte und Messverfahren

Industrial, scientific and medical equipment - Radio-frequency disturbance characteristics -
Limits and methods of measurement

DIN EN 61326-1 (Ausgabe / Version 2013-07)

Elektrische Mess-, Steuer-, Regel- und Laborgerate - EMV-Anforderungen - Teil 1: Allgemeine
Anforderungen

Electrical equipment for measurement, control and laboratory use - EMC requirements --
Part 1: General requirements

C V4
. Frank Tscherney .
Unterschrift: W/ (Geschéftsfiihrer / General manager) Giefien, 17.01.2017
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